IT-MÜCKE

Fujitsu Siemens Amilo A1650G: WLan unter Ubuntu will nicht - oder doch?

28.06.2011

Ein Kunde brachte vor kurzem einen FS Amilo A1650G Laptop zu mir ins Büro: Problem war eine scheinbar kaputte Festplatte - siehe Blog-Beitrag. Bei dem Festplatten-Problem konnte ich sehr einfach helfen. Nun stellte sich die Frage, ob der Kunde ein alternatives Betriebssystem nutzen möchte: Ubuntu Linux. Der Kunde war gerne bereit es damit zu versuchen und dadurch viele Probleme - unter anderem auch das scheinbare Versagen der Festplatte - zukünftig zum umgehen.

Ich installierte also Ubuntu 10.04 LTS und musste feststellen, dass das WLan nicht richtig funktionierte. Die SSIDs der WLans in der Umgebung wurden zwar aufgelistet, aber jeder Verbindungsversuch führte dazu, dass immer wieder nach den Zugangsdaten gefragt wurde - auch wenn das Passwort des WLans bekannt war.

Ursache lag schlussendlich in einem fehlenden Treiber: acer-wmi.

Lösung des Problems wir folgt:

  1. In einem Terminal versuchsweise das Modul laden:
    sudo modprobe acer-wmi
  2. Die WLand-LED müsste aufleuchten.
  3. Zugang zum WLan testen.
  4. Wenn es funktioniert, das Modul automatisch bei jedem Systemstart laden lassen:
    dazu die Datei /etc/modules bearbeiten, z.B. mit vim:
    sudo vim /etc/modules
  5. Zeile anfügen:
    acer-wmi
  6. Speichern.

Nun wird bei jedem Systemstart das Modul acer-wmi geladen und WLan funktioniert.

Quelle: ubuntuforums.org


zurück

Cookies helfen bei der Bereitstellung von Inhalten. Durch die Nutzung dieser Seiten erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Rechner gespeichert werden. Weitere Information