IT-MÜCKE

Xataface-Fehler mit templates_c-Verzeichnis

Beitragsdatum 13.09.2017
Letzte Aktualisierung -
Betrifft Xataface 2.3.1 (u.a.)

Problem

  • Ich erhielt bei einer Xataface-Anwendung seit kurzer Zeit am unteren Rand der Anwendung einen Hinweis auf eine PHP-Exception
  • In der Logfile der Anwendung fanden sich Einträge wie folgt:
    [Wed Sep 13 07:52:02.176799 2017] [proxy_fcgi:error] [pid 4267] [client 2.245.72.179:47392] AH01071: Got error 'PHP message: PHP Warning:  file_put_contents(/var/www/vhosts/xxx/templates_c/ResultList-746c73dce6c7ef594220fa529f5db0a0.js): failed to open stream: Permission denied in /var/www/vhosts/xxx/xataface-2.1.3/Dataface/JavascriptTool.php on line 453\nPHP message: PHP Fatal error:  Uncaught Exception: JavascriptTool failed cache the request's javascript file.  Please check that your application has a templates_c directory and that it is writable. in /var/www/vhosts/xxx/xataface-2.1.3/Dataface/JavascriptTool.php:455\nStack trace:\n#0 /var/www/vhosts/xxx/xataface-2.1.3/Dataface/JavascriptTool.php(274): Dataface_JavascriptTool->compile()\n#1 /var/www/vhosts/xxx/xataface-2.1.3/modules/XataJax/XataJax.php(55): Dataface_JavascriptTool->getHtml()\n#2 /var/www/vhosts/xxx/xataface-2.1.3/Dataface/ModuleTool.php(185): modules_XataJax->block__after_global_footer(Array)\n#3 /var/www/vhosts/xxx/xataface-2.1.3/Dataface/Table.php(5429): Dataface_ModuleTool->displayBlock('after_global_fo...', Array)\n#4 /var/www/vhosts/xxx/xataface-2.1.3/public-api.php(569): Dataface_Table->displayBlock('after_global_fo...', Array)\n#5 /var/www/...\n', referer: https://xxx/index.php?-table=tbl_objekte&-sort=objekte_objid+asc&-action=list&-cursor=0&-limit=200&-mode=list&kunden_name=xxx&&objekte_status==Produktiv

Ursache

  • Es gab wohl ein Problem mit dem Verzeichnis templates_c
  • Ob ein Rechteproblem oder ein Problem mit korrupten Dateien ist mir nicht ganz klar
  • Dateien aus dem genannten Verzeichnis konnten jedenfalls nicht geöffnet werden - Auszug aus dem Log:
    PHP message: PHP Warning:  include(): Failed opening '/var/www/vhosts/xxx/templates_c/dataface/%%D9^D9A^D9A96E24%%Dataface_DeleteForm.html.php' for inclusion

Lösung

  • Auch nachdem ich vorsichtshalber die Rechte anpasste (für den Webserver schreibbbar machen), kam weiterhin der Fehler
  • Also löschte ich (nach Erstellung einer Sicherung) alle Inhalte aus dem Verzeichnis
  • Nun läuft Xataface wieder rund, die Inhalte im templates_c-Verzeichnis werden wieder erstellt, Fehler gibt es keine mehr

Ähnliche Themen im blog:
xataface, php


zurück

Cookies helfen bei der Bereitstellung von Inhalten. Durch die Nutzung dieser Seiten erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Rechner gespeichert werden. Weitere Information