IT-MÜCKE

NAS4Free - Einhängen der Platten klappt nicht

Beitragsdatum 19.05.2017
Letzte Aktualisierung 08.02.2019
Betrifft XigmaNAS, NAS4Free und ggf. FreeNAS: diverse Versionen

NAS4Free und XigmaNAS sind quasi identisch - nur der Name hat sich geändert.
Dieser Artikel gilt daher für beide Systeme (und eingeschränkt auch für FreeNAS).

Problem

  • Nach dem Reboot eines NAS4Free-Servers (siehe NAS, NAS4Free hier im Blog bzw. FreeNAS hier im Blog und nas4free.org) werden die Platten/Raids nicht mehr korrekt eingehängt
  • Im system-Log (/var/log/system.log) findet sich folgende oder ähnliche Fehlermeldungen:
    root: Error: Failed to mount /dev/ufsid/55c572b5840fe740 using UFS
    root: mount: /dev/ufsid/55c572b5840fe740: R/W mount of /mnt/nas01 denied. Filesystem is not clean - run fsck. Forced mount will invalidate journal contents: Operation not permitted
    root: Error: Failed to create directory /mnt/nas01

Ursache

  • Warum auch immer - es ist ein Filesystemcheck (fsck) notwendig

Lösung

  • Über die WebGUI kann ein fsck durchgeführt werden
  • In der WebGUI: Festplatten → Einhängepunkt → Fsck
  • Dort jeweils die Platten auswählen und prüfen
  • Danach können sie (wenn keine echten Fehler vorliegen) wieder eingehängt werden

Ähnliche Themen im blog:
xigmanas, nas4free, freenas, fsck, freenas


zurück

Cookies helfen bei der Bereitstellung von Inhalten. Durch die Nutzung dieser Seiten erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Rechner gespeichert werden. Weitere Information